自适应均线系统的改进,求助AMA考夫曼自适用型均线改通达信

内容导航:
  • 求助AMA考夫曼自适用型均线改通达信
  • 均线本身具有滞后性,但是应该如何正确利用
  • 考夫曼自适应均线公式在天津鑫桂平台上的应用问题
  • 求大神,把下面自适应均线通达信版公式改为博易大师版的?
  • 怎么编写2条均线相差10%的距离通达信
  • 什么是考夫曼自适应移动平均线Kaufman Adaptive Moving Average
  • Q1:求助AMA考夫曼自适用型均线改通达信

    {考夫曼自适应变色均线系统}
    N:=10;
    M:=30;
    DIR1:=ABS(CLOSE-REF(CLOSE,N));
    VIR1:=SUM(ABS(CLOSE-REF(CLOSE,1)),N);
    ER1:=DIR1/VIR1;
    CS1:=ER1*(0.8-2/8)+2/8;
    CQ1:=CS1*CS1;
    AMA1:EMA(DMA(CLOSE,CQ1),2) ,COLORWHITE;
    DIR2:=ABS(CLOSE-REF(CLOSE,M));
    VIR2:=SUM(ABS(CLOSE-REF(CLOSE,1)),M);
    ER2:=DIR2/VIR2;
    CS2:=ER2*(0.8-2/24)+2/24;
    CQ2:=CS2*CS2;
    AMA2:EMA(DMA(CLOSE,CQ2),2),COLORGREEN,LINETHICK2;
    AMA3:IF(AMA2/REF(AMA2,1)>0.997,AMA2,DRAWNULL),COLORBLUE,LINETHICK2;
    AMA4:IF(AMA2/REF(AMA2,1)>1.001,AMA2,DRAWNULL),COLORRED,LINETHICK2;

    Q2:均线本身具有滞后性,但是应该如何正确利用

    终南望余雪(祖咏)

    Q3:考夫曼自适应均线公式在天津鑫桂平台上的应用问题

    DIR1:=ABS(CLOSE-REF(CLOSE,2));
    VIR1:=SUM(ABS(CLOSE-REF(CLOSE,1)),2);
    ER1:=DIR1/VIR1;
    CS1:=ER1*(0.8-2/8)+2/8;
    CQ1:=CS1*CS1;
    AMA1:EMA(DMA(CLOSE,CQ1),2) ,COLORWHITE;
    DIR2:=ABS(CLOSE-REF(CLOSE,8));
    VIR2:=SUM(ABS(CLOSE-REF(CLOSE,1)),8);
    ER2:=DIR2/VIR2;
    CS2:=ER2*(0.8-2/8)+2/8;
    CQ2:=CS2*CS2;
    AMA2:EMA(DMA(CLOSE,CQ2),2),COLORGREEN,LINETHICK2;
    {PARTLINE(AMA2/REF(AMA2,1)>0.998,AMA2),COLORBLUE,LINETHICK2;
    PARTLINE(AMA2/REF(AMA2,1)>1.001,AMA2),COLORRED,LINETHICK2;}
    {最后两行是使画线变色的句子不用也可以,我用花括号括上了,如果愿意可将其删除,这样公式就可以用了,功能是一样的只是线条不变色了}

    Q4:求大神,把下面自适应均线通达信版公式改为博易大师版的?

    可以修改

    效果如下图

    Q5:怎么编写2条均线相差10%的距离通达信

    (ma1/ma2)=10%

    Q6:什么是考夫曼自适应移动平均线Kaufman Adaptive Moving Average

    考夫曼自适应移动平均线KAMA是一种均线,它最初由Perry J. Kaufman在其著作Smarter Trading 精明交易者中提出的。
    我们常用的移动均线有简单移动均线、加权移动均线以及指数式移动均线等。我们知道长周期的均线系统是最可靠的,但是它却带有严重的滞后行;短周期的均线系统虽然能快速反映股票的走势,但是却又难以抵抗股票“噪音”的干扰,多数情况下短周期所给出的趋势信号都是不准确的!
    为了避免噪音产生的虚假信号,同时又想消除某些长线趋势中的滞后特性,考夫曼提出了一种“自适应”的均线系统——考夫曼自适应移动均线系统(简称AMA)。AMA可以在市场沿一个方向快速移动时,使用快的移动平均值,而当价格在横盘的市场中拉锯时,使用慢速的移动平均值。

    上一篇:上一篇:铜的基本面分析方法
    下一篇:下一篇:什么样的涨停板最强势
    • 评论列表

    发表评论: